Changelly supports Ethereum Byzantium Hard Fork

Uncategorized by Maret 0 Comments
Changelly supports Ethereum Byzantium Hard Fork

Ethereum is officially hardforked. The new fifth mandatory update of Ethereum has locked in at 05.22 UTC. The update represents Ethereum Improvement Protocols (EIP), a set of improvements for the entire platform. This is the first part of the large upgrade under name Metropolis that aims to transform the overall outlook of the Ethereum ecosystem as a whole. Let’s take a closer look at this.


It is the wide-scale upgrade that was firstly introduced in 2015 as a batch of planned improvements. Metropolis has a range of enhancements and benefits making Ethereum, more secure, fast and scalable comparing with other platforms.

Metropolis consists of two phases: Byzantium that happened just recently, and Constantinople that is anticipated for 2018.

The improvements Metropolis brings are as follows.

  • Zk-SNARKS adoption

The upgrade is expected to integrate so-called zk-SNARKS, a cryptographic engine pioneered by Zcash. This measure will enable direct ETH-ZEC trade executions between two blockchains and provide new possibilities for the platform.

  • Proof-of-Stake

The mining process will take less electricity due to switching to the PoS consensus. Reducing energy spent for mining is one of the goals to make mining processes more affordable and ecological.

  • Easier programming and clients

This feature will lower entry barriers for novices and developers providing them with new lighter clients and upgraded programming.

The Byzantium hard fork aims to resolve vulnerability issues, such as resistance to DDoS attacks and fix critical bugs. The new changes were activated at block number 4.37mil. (4,370,000). To track the process, click here.

If you use a full node wallet, such as Parity or Mist, please make sure that your wallet is upgraded to the latest version. Other lightweight wallets like Jaxx or Myetherwallet already fully support the hard fork, so you don’t need to upgrade them. Since the upgrade is mandatory, clients working on an old chain are no longer supported.

Beware of scam and suspicious emails!

For any help, please contact us at [email protected]

Leave a reply

Your email address will not be published.

You may use these HTML tags and attributes:

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>